Generatore di discorsi per... apprendisti politici

Stampa
( 2 Votes ) 
Valutazione attuale:  / 2
ScarsoOttimo 
Categoria: Informatica
Data pubblicazione
Scritto da Andrea Visite: 3893

Generatore di discorsi per... apprendisti politici

Divertente esempio di generatore casuale di... brevi discorsi programmatici!

In questo esempio impareremo ad usare le funzioni di ricerca su una tabella.

Apriamo una cartella di lavoro di Excel.

Sul Foglio2 scriviamo 1 in B1 e 2 in C1; selezioniamo le due celle e trasciniamo orizzontalmente il solito quadratino di riempimento in modo da avere i numeri da 1 a 7.
Scriviamo poi 0 in A2 e 1 in A3; selezioniamo le due celle e trasciniamo verticalmente il solito quadratino di riempimento in modo da avere i numeri da 1 a 9.


Ora copiamo (con Copia & Incolla) le righe seguenti:
(eventualmente adattiamo la larghezza delle colonne selezionando l'intero foglio con un clic nel rettangolino all'incrocio tra le intestazioni di riga e quelle di colonna, e poi con doppio clic sulla linea di separazione tra le intestazioni di due colonne)

in B2-B11
L'utenza potenziale
Il bisogno emergente
Il quadro normativo
La valenza epidemiologica
Il nuovo soggetto sociale
L'approccio programmatorio
L'assetto politico-istituzionale
Il criterio metodologico
Il modello di sviluppo
Il metodo partecipativo

in C2-C11
si caratterizza per
privilegia
prefigura
riconduce a sintesi
persegue
estrinseca
si propone
presuppone
porta avanti
auspica

in D2-D11
il ribaltamento della logica assistenziale preesistente
il superamento di ogni ostacolo e/o resistenza passiva
un organico collegamento interdisciplinare ed una prassi di lavoro di gruppo
la puntuale corrispondenza fra obiettivi e risorse
la verifica critica degli obiettivi costituzionali e l'individuazione di fini qualificanti
il riorientamento delle linee di tendenza in atto
l'accorpamento delle funzioni ed il decentramento decisionale
la ricognizione del bisogno emergente e della domanda non soddisfatta
la riconversione ed articolazione periferica dei servizi
un corretto rapporto fra strutture e sovrastrutture

in E2-E11

nel primario interesse della popolazione
senza pregiudicare l'attuale livello delle prestazioni
al di sopra di interessi e pressioni di parte
secondo un modulo di interdipendenza orizzontale
in una visione organica e ricondotta ad unità
con criteri non dirigistici
al di là delle contraddizioni e difficoltà iniziali
in maniera articolata e non totalizzante
attraverso i meccanismi della partecipazione
senza precostituzione delle risposte

in F2-F11
sostanziando e vitalizzando
recuperando ovvero rivalutando
ipotizzando e perseguendo
non assumendo mai come implicito
fattualizzando e concretizzando
non sottacendo ma anzi puntualizzando
potenziando ed incrementando
non dando certo per scontato
evidenziando ed esplicitando
attivando ed implementando

in G2-G11
nei tempi brevi anzi brevissimi
in un'ottica preventiva e non più curativa
in un ambito territoriale omogeneo ai diversi livelli
nel rispetto della normativa esistente
nel contesto di un sistema integrato
quale sua premessa indispensabile e condizionante
nella misura in cui ciò sia fattibile
con le dovute ed imprescindibili sottolineature
in termini di efficacia e di efficienza
a monte ed a valle della situazione contingente

in H2-H11
la trasparenza di ogni atto decisionale.
la non sanitarizzazione delle risposte.
un indispensabile salto di qualità.
una congrua flessibilità delle strutture.
l'annullamento di ogni ghettizzazione.
il coinvolgimento attivo di operatori ed utenti.
l'appianamento delle discrepanze e discrasie esistenti.
la ridefinizione di una nuova figura professionale.
l'adozione di una metodologia differenziata.
la demedicalizzazione del linguaggio.

Selezioniamo ora il Foglio1 e scriviamo i valori da 1 a 7 nelle celle A2-A8, ad esempio con il solito riempimento automatico.
Nella cella B2 si inserisce la formula:

=INT(CASUALE()*10)

cioè si prende l'intero arrotondato per difetto di un numero casuale (non ha argomenti: ()) compreso tra 0 e 10 (i numeri casuali sono >=0 e <1)

Nella cella C2 inseriamo invece una formula: =CERCA.VERT(....)

Per capire quali sono i suoi parametri inseriamo la formula non a mano ma cliccando su Inserisci/Funzione...
Nella finestra di dialogo che si apre scegliamo la categoria Ricerca e riferimento, quindi CERCA.VERT come nome di funzione.
Sotto si leggono i nomi dei parametri. Cliccando su Ok si apre un'altra finestra in cui si possono inserire i parametri. Leggete attentamente le istruzioni.

Valore: è il valore da cercare
Matrice_Tabella: è la zona in cui lavorare e cercare il valore
Indice: è il numero di colonne che occorre contare per trovare il valore da estrarre e scrivere nella cella contenente la formula
Intervallo: è una variabile booleana (vero/falso) che serve per indicare se l'elenco è ordinato oppure no.

la formula da inserire è:

=CERCA.VERT(B2;Foglio2!$A$2:$H$11;A2+1)&" "

Per inserire automaticamente questi valori occorre cliccare sulle celle interessate o scrivere direttamente il riferimento. Il blocco del riferimento con il $ si ottiene cliccando più volte su F4. Lo spazio aggiunto alla stringa risultante con & serve per separare una frase dall'altra.
Copiamo le formule inserite in B2 e C2 a anche nelle altre righe, fino alla riga 8: si ottengono i brani estratti in funzione dei numeri casuali scritti nella colonna B.

Infine, leghiamo assieme le varie frasi inserendo in A1 la formula:

=C2&C3&C4&C5&C6&C7&C8

Nella cella B2 si dovrebbe leggere l'intero discorso! Occorre però adattare altezza e larghezza della cella perché il testo invade le altre colonne.
Nascondiamo le righe da 2 a 8: selezioniamole mettendo il puntatore sulle intestazioni di riga e scegliendo dal menù contestuale (clic destro) la voce Nascondi.
Allarghiamo bene la cella trascinando la linea di separazione tra le righe e tra le colonne, andiamo sul menù Formato/Celle... e sulla Scheda Allineamento scegliamo Testo a capo.
Mettiamo un carattere abbastanza grande, uno sfondo colorato e una cornice alla cella ed il gioco è fatto: provate con numeri casuali diversi per vederne l'effetto; come? Basta costringere Excel a ricalcolare il foglio inserendo un valore in una cella qualunque; ma molto più semplicemente basta premere F9, che corrisponde al comando Calcola (lo si scopre in Strumenti/Opzioni, scheda Modifica).

Buon divertimento!

Joomla 1.7 Templates designed by College Jacke